Wileyfox Swift unter LOS 14.1 bootet nach TWRP Update nicht mehr

  • Hallo


    Vielleicht kann mir hier jemand helfen.



    Habe wie beschrieben das Swift mit aktuellen LOS laufen.


    Habe letzte Woche über "offizielle TWRP" App TWRP von 3.1 auf TWRP 3.2 geupdatet. Es handelt sich hier jeweils um das TWRP für Crackling (Wileyfox Swift)


    Lief alles ganz normal durch. Nach einigen Stunden habe ich bemerkt das das Swift im TWRP läuft und nicht im LOS.


    Ausschalten, Neu starten, Batterie rein/raus hat alles nix gebracht LOS startete nicht nur TWRP.



    Habe dann in/mit TWRP Speicher gelöscht bis auf die SD-Karte und mein letztes TWRP System BackUp installiert.


    Das Swift startete jetzt im LOS aber hatte komischerweise kein Root mehr.


    Dachte ich mir gut spielste über TWRP das "LineageOS addon SU-14.1-arm64-signed" auf.


    Da kam im TWRP die Fehlermeldung "Prüfung der zip-Signatur fehlgeschlagen".


    Dachte ich mir, vielleicht hat das TWRP 3.2 einen Fehler, gibt ja mitlerweile TWRP 3.2.1.


    Bin in die "Offizielle TWRP" App und wollte TWRP 3.2.1 installieren.



    Das funktionierte aber nicht. Die Installation lief nicht durch. Warum auch immer?



    Nun hab ich mir gedacht, hast ja einige TWRP System BackUps auf der SD liegen nimmste mal eine frühere so aus 06-2017.


    In TWRP alles gelöscht bis auf die SD und das BackUp installiert.



    Nun hab ich das Problem das die Installation des BackUp nicht durchläuft und sich TWRP aushängt.


    Ich kann nur die Batterie raus nehmen um diese TWRP Schleife zu beenden.


    LOS bootet jetzt blöderweise auch nicht mehr.



    Ich habe die Vermutung das das TWRP 3.2 Crackling einen Fehler hat.



    Was kann ich nun tun?


    Kann ich das zuletzt funtionierende TWRP 3.1 Crackling IMG in TWRP selbst installieren?


    Oder muß ich das wieder mit ADB tun?


    Habe ich womöglich beim aufspielen des SystemBackUp mit TWRP etwas falsch gemacht?


    Ich habe verschiedene SystemBackUp Dateien auf der SD liegen. Die letzte von Anfang Dezember von vor dem TWRP Update, aber auch von 07 oder 04 2017.


    Ich würde ungern LOS komplet neu installieren.


    Aber das sollte doch als letzter Ausweg auch noch gehen oder?



    Gruß & Dank Uwe

  • Moin, das TWRP installieren mit dem du dein letztes Backup gemacht hast. Versuch dann dieses Backup wieder herzustellen.

    (du wirst beim Wiederherstellen gefragt was du wieder herstellen willst. Falls du auch 'Recovery' gesichert hattest, mach dort den Haken raus!)

    OnePlus 2 | *Link ausgeblendet*
    Bitte registriere oder Melde Dich an um alle Links im Forum zu sehen. Klick dazu hier | RR |


    02adeb052828804ae53a85df31349cad3076d177.jpg

  • Hallo

    Muß ich das TWRP mit ADB auf das Swift spielen oder kann ich auch in TWRP das TWRP.img installieren?

    Hat sonst jemand Problem mit dem TWRP 3.2 Crackling gehabt?


    Gruß

  • Noch etwas.


    In der "offiziellen TWRP" APP habe ich auch schon versucht das funktionierende TWRP Crackling 3.1 und das 3.2.1 zu installieren.

    Die Installation lief aber warum auch immer nicht durch.

  • Bist du direkt von Android 6.0, also quasi CyanogenOS auf LOS gegangen oder war da Wileyfox-Stockrom drauf?

  • Der Wechsel CyanogenOS zu LOS war Ende 2016 Anfang 2017.

    Wenn ich mich recht erinnere bin ich vom CyanogenOS auf LOS 13.x und dann auf LOS 14.x gewechselt.

    Mit oder um den Wechsel von LOS 13.x zu LOS 14.x dächte ich das ich da das TWRP 3.0 oder schon 3.1 eingesetzt habe.

  • Dann könnte das Problem auch am Bootloader liegen..


    Hab so ein ähnliches Problem: Sobald ich von TWRP 3.1 upgrade will, funktioniert das Handy nicht mehr. Du müsstest also dann eher auf Stock (das neue Wileyfox_Stock), danach wieder BL entlocken, rooten und wieder auf LOS. Oder du bleibst auf altem TWRP (was auch nicht schlimm ist eigentlich)

  • Hallo Blackrider, das hört sich ja nicht gut an.

    Ich dachte irgendwo gelesen zu haben das man für LOS 15.x mindestens TWRP 3.2.x benötigt.

    Somit müsste ich ja dann zukünfig zwingend den Umweg den Blackrider beschrieb gehen. Oder täusche ich mich da?


    BlackRider noch mal zu deinem Ablauf nicht das ich da was falsch verstehe:
    - hast du das Wilexfox_Stock mit dem TWRP 3.2.x aufgespielt oder muß ich dazu auch erst zurück zu TWRP 3.1.x?

    - Woher bekommt man das Wilexfox_Stock? Hättest du evtl. einen Link?

    - nach erfolgfreichem aufspielen von Wilexfox_Stock kann ich dann direkt LOS 14.1?


    Vorgehen nach meinem Wissen wäre also wie folgt:

    1. zurück zu TWRP 3.1.x über Installation des TWRP 3.1 Crackling.img im bestehenden TWRP 3.2.x --> dort dann ins Recovery booten so das TWRP 3.1.x bootet, dort dann Neustart --> richtig so?

    2. in TWRP 3.1.x Löschen von "Dalivk / ART Cache" + "Cache" + "System" + "Data" + "Internal Storage"

    3. in TWRP 3.1.x danach installieren des Wilexfox_Stock anschließend Neustart so das das Wilexfox_Stock startet

    4. muß ich jetzt hier im Wilexfox_Stock irgend etwas machen? Muß ich das Wilexfox_Stock "Root" freischalten?

    5. ins TWRP 3.1.x booten

    6. in TWRP 3.1.x Löschen von "Dalivk / ART Cache" + "Cache" + "System" + "Data" + "Internal Storage"

    7. in TWRP 3.1.x danach installieren des aktuellen LOS Crackling 14.1 anschließend Neustart so das das LOS 14.1 startet

    8. in TWRP 3.1.x Installation des "TWRP 3.2.1 Crackling.img" --> anschließend dann ins Recovery booten so das TWRP 3.2.1 bootet, dort dann Neustart zum LOS 14.1


    Das alles hätte dann aber den Nachteil das alle mein Einstellungen vom zuletzgenutzten LOS 14.1 mit allen APPs weg sind.

    Oder bekomme ich meine letzte mit TWRP 3.1.x angelegte Sicherung von LOS 14.1 irgendwie wieder aufgespielt?


    viel Text und Fragen sorry


    Gruß & Dank Uwe

  • Also ganz grob gesagt hatte ich bisher keine Probleme mit dem alten TWRP, also unter TWRP 3.2.x.x, irgendwas zu flashen.


    Die Stockrom kannst du über 2 Wege installieren....

    Schau einfach mal auf dem blauen F nach Anleitungen, da sind einige Verfahrenswege beschrieben

    https://www.facebook.com/officialwileyfox/videos/1866588893652427/


    Sobald du auf Stock bist kannst du eigentlich wieder ganz normal von vorne anfangen.


    Bootloader entsperren

    TWRP installieren

    LOS flashen

    Gapps flashen

    Magisk oder SuperSU hinterher..


    Danach sollte es ganz normal wieder funktionieren.

    Falls dir das alle zu viel Aufwand ist bleib einfach so lange auf der alten TWRP wie es nur geht...

  • Hallo Blackrider

    Stehe etwas auf dem Schlauch, was meinst die mit

    Schau einfach mal auf dem blauen F nach Anleitungen, da sind einige Verfahrenswege beschrieben

    Weist du ob man für LOS 15.x mindestens TWRP 3.2.x benötigen wird?

  • Hallo Blackrider

    Stehe etwas auf dem Schlauch, was meinst die mit

    Weist du ob man für LOS 15.x mindestens TWRP 3.2.x benötigen wird?

    Hier noch ein hilfreicher Link

    *Link ausgeblendet*
    Bitte registriere oder Melde Dich an um alle Links im Forum zu sehen. Klick dazu hier

    Und noch eine andere Anleitung

    *Link ausgeblendet*
    Bitte registriere oder Melde Dich an um alle Links im Forum zu sehen. Klick dazu hier


    Ich kann es nicht genau sagen, aber ich konnte crDroid 4.0 (basiert auf Android 8.0) ganz normal flashen.

  • Hallo, noch mal ein Update was ich jetzt gemacht habe.


    In TWRP 3.2.0 habe ich das TWRP 3.1.x Crackling.img installiert.

    Dann in TWRP 3.2.0 Neustart nach recovery.

    Es startet TWRP 3.1.x, wo ich dann meine letztes mit TWRP 3.1.x abgelegte Backup wiederhergestellt habe.


    Läuft bisher ohne das ich Probleme festgestellt habe.

    Mal schauen wenn ich dann mal auf LOS 15.x wechseln will ob ich dann noch mit dem TWRP 3.1.x hin komme.

    Den von Blackrider beschriebenen Weg habe ich mir erstmal erspart.

    Frohes Fest euch

    Uwe

  • Na, sagte ich doch

    Moin, das TWRP installieren mit dem du dein letztes Backup gemacht hast. Versuch dann dieses Backup wieder herzustellen.

    (du wirst beim Wiederherstellen gefragt was du wieder herstellen willst. Falls du auch 'Recovery' gesichert hattest, mach dort den Haken raus!)

    OnePlus 2 | *Link ausgeblendet*
    Bitte registriere oder Melde Dich an um alle Links im Forum zu sehen. Klick dazu hier | RR |


    02adeb052828804ae53a85df31349cad3076d177.jpg

  • Hallo

    Heute ist scheinbar das offizielle LOS 15.1 erschienen: *Link ausgeblendet*
    Bitte registriere oder Melde Dich an um alle Links im Forum zu sehen. Klick dazu hier


    Nun stellt sich mir die Frage wie vorgehen, wenn ich es installieren will.


    Ich habe ja weiterhin noch TWRP 3.1 auf dem Gerät mit LOS 14.1.


    Mittlerweile gibt es TWRP 3.2.3 :*Link ausgeblendet*
    Bitte registriere oder Melde Dich an um alle Links im Forum zu sehen. Klick dazu hier


    Es stellen sich mir da div. Fragen:

    1. braucht es zwingend TWRP 3.2.x um Los 15.1 aufzuspielen?

    2. bekomme ich das LOS 15.1 über den LOS eigenen Updater oder muß ich händisch mit TWRP installieren?

    3. was muß ich in TWRP löschen um sauber von LOS 14.1. auf LOS 15.1 zu wechseln, "Dalivk / ART Cache" + "Cache" + "System" + "Data" + "Internal Storage", oder ist das nicht nötig?

    4. hat jemand hier LOS 15.1 offiziell laufen? Zufrieden damit?


    Habe gleich erst mal eine Sicherung gemacht von dem LOS 14.1


    Gruß & Dank Uwe